WordPress : the_content retourne vide lors de l’ajout de détails SEO

Publié par Jean-Michel le

J’utilise le thème Thesis et je voulais un style personnalisé pour mes pages. J’ai donc créé un modèle personnalisé tout en utilisant des crochets et des fonctions de thèse, le cas échéant. Je le fais avec une solution similaire à la méthode décrite ici afin que d’autres contributeurs puissent également utiliser les thèmes dans leurs pages.

Lire également:  insérer plusieurs shortcodes dans un shortcode wordpress

Je reçois le contenu du message en utilisant la fonction the_content().

Bien que cela fonctionne normalement et renvoie le contenu des pages, si je spécifie les détails du référencement (méta-titre, mots-clés, description, etc.), the_content() renvoie un blanc.

Pourquoi l’ajout de méta-détails à une page devrait-il affecter le contenu de cette façon ? J’apprécierais si quelqu’un peut m’aider avec ça.

Lire également:  Wordpress : Liste les pages enfants du parent de la page actuelle

Merci.

Solution n°1 trouvée

pourriez-vous poster votre code de modèle? Il y a peut-être une erreur dans votre html. des balises non fermées ou quelque chose.

aussi quel résultat cela vous donne-t-il? est-il aussi vide ?

$content = get_the_content();
Catégories : Wordpress

Jean-Michel

Jean-Michel est en charge de la partie blog du site. Il met en place la stratégie de contenu et répond aux questions fréquentes sur Wordpress.

0 commentaire

Laisser un commentaire

Avatar placeholder

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *