Migration du thème WordPress Local vers Live Assets non chargé

Publié par Jean-Michel le

J’ai un thème WordPress personnalisé entièrement fonctionnel construit à partir de traits de soulignement servis localement via MAMP. Normalement, lors de la migration vers un serveur en direct, je déplace le répertoire wp-content et le fichier .sql, trouve/remplace par l’URL en direct appropriée. Parfois, je dois mettre à jour les permaliens pour que tout fonctionne correctement sur le serveur en direct. J’ai suivi ces étapes avec mon site actuel et le thème s’affiche cassé. L’image du thème ne s’affiche pas et aucun élément hébergé n’est en cours de chargement (les éléments CDN arrivent). Je ne reçois aucune erreur PHP et le reste du site fonctionne correctement, ce qui signifie que les pages sont toutes liées. J’ai essayé ce processus plusieurs fois sans succès, avec des plugins et avec des plugins désactivés. Les thèmes par défaut se chargent correctement.

Lire également:  Wordpress : Ajouter des div supplémentaires aux éléments de navigation WordPress

Quelqu’un a-t-il déjà rencontré quelque chose comme ça ou sait-il ce que je fais de mal?

Solution n°1 trouvée

Résolu : il s’agissait d’un problème d’autorisations de dossier qui a été résolu avec un chmod vers le dossier parent contenant les actifs concernés. Le niveau d’autorisation approprié dans ce cas était 755.

Lire également:  WordPress : Comment renommer une image lors du téléchargement avec la date actuelle ?

Renforcer WordPress

Catégories : Wordpress

Jean-Michel

Jean-Michel est en charge de la partie blog du site. Il met en place la stratégie de contenu et répond aux questions fréquentes sur Wordpress.

0 commentaire

Laisser un commentaire

Avatar placeholder

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *