WordPress : « Le thème sans sidebar.php est obsolète »

Publié par Jean-Michel le

Je suis en train de créer un thème wordpress personnalisé. Lorsque j’active le debug, j’obtiens ce message :

Remarque : le thème sans sidebar.php est obsolète depuis la version 3.0 sans alternative disponible. Veuillez inclure un modèle sidebar.php dans votre thème. dans /var/www/wp2/wp-includes/functions.php à la ligne 2968

Cependant, j’ai sidebar.php dans mon thème. Il est copié et non édité, depuis wp-includes/theme-compat

Lire également:  comment supprimer la barre de défilement horizontale dans wordpress

Qu’est-ce que je fais mal?

Solution n°1 trouvée

L’appel provient en fait de themes compatce que vous pouvez lire ici dans la source.

J’imagine donc que vous avez simplement copié collé le contenu complet et donc simplement ajouté l’ _deprecated_file()appel également. :RÉ

Leçon à tirer de ceci : ne copiez jamais aveuglément des choses sans comprendre ce qu’elles font et pourquoi elles le font.

Catégories : Wordpress

Jean-Michel

Jean-Michel est en charge de la partie blog du site. Il met en place la stratégie de contenu et répond aux questions fréquentes sur Wordpress.

0 commentaire

Laisser un commentaire

Avatar placeholder

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *