WordPress : Aide avec les mods de base

Publié par Jean-Michel le

Je reçois cette erreur sur mon site tout d’un coup et je ne sais pas comment la corriger.

Avertissement : Utilisation d’une constante indéfinie core_mods – supposée ‘core_mods’ (cela générera une erreur dans une future version de PHP) dans /nfs/c10/h07/mnt/144394/domains/nationsfg.com/html/wp/wp-content /themes/nationsfg/functions.php à la ligne 50

Solution n°1 trouvée

D’après l’erreur fournie, il semble que vous ayez ajouté du code personnalisé à votre fichier functions.php dans votre thème. Suggérez de commenter les dernières modifications que vous avez apportées, mais l’erreur indique clairement que la ligne 50 est le coupable, ce serait donc un bon point de départ si vous n’êtes pas sûr.

Si cela s’est produit depuis la mise à jour vers WP v5.5 (ou une nouvelle version de PHP sur votre serveur), le code que vous utilisez est probablement obsolète, ce qui peut expliquer pourquoi cette erreur s’affiche soudainement.

Je ne recommanderais pas de le faire, mais comme il s’agit d’un avertissement, vous pouvez également désactiver wp_debug(régler sur false) à la fin de file wp-config.php. Cela ne fera que masquer le message, cela ne résoudra pas le problème et il est possible de se transformer en quelque chose de plus grave avec le temps.

Catégories : Wordpress

0 commentaire

Laisser un commentaire

Avatar placeholder

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *